Dynamic Routing OSPF CISCO – CCNA – Packet Tracer

 Pada Posting Kali ini Lanjut lagi dalam pembahasan Protocol Dynamic Routing, yang sebelumnya Protocol Dynamic Routing menggunakan EIGRP, untuk saat ini yang kita bahas adalah Dynamic Routin OSPF(Open Shorthest Path), untuk konsep dasar dari OSPF sendiri ialah memiliki open standard Protocol yang bisa di implementasikan pada vendor Router manapun, memiliki Klasifikasi Routing Protocol IGP (interior Gateway Protocol) yang dalam implementasinya jaringan internal dimana kita memiliki hak akses penuh terhadap jairngan tersebut, bagus di gunakan pada jaringan skala sedang maupun besar, memiliki tingkatan pembagian Sub Area yang berguna sebagai group dari router.

#. Fitur OSPF:
-          OSPF merupakan routing protocol open standar, yang bisa di implementasikan pada semua vendor router
-          Link-State Protocol
-          OSPF bekerja menggunakan Algorithma Djikstra
-          HopCount Unlimitide
-          Metric: Perhitungan (Cost: 10^8 / BW)
-          Administrative Distance: 110
-          Classless Routing Protocol
-          Mendukung VLSM dan CIDR
-          Hanya mendukung Equal Cost Load Balancing
-          Menggunakan konsep Area yang berguna untuk memudahkan manajemen dan control Traffic
-          Menyediakan design hirearki pada Multiple Area
-          Wajib memiliki Area 0 (Backbone) dan None Backbone area wajib terhubung ke Bacbone area
-          Mendukung Authentikasi
-          Update melalui Multicast Address: 224.0.0.5
-          Konvergensi Cepat (waktu yang di butuhkan untuk mencari Rute ketika best rute Down)
-          Mengirimkan Packet Hello untuk bertukar Informasi neighbor Route setiap 10 second
-          Trigger/incrimental Updates (router mengirim Update pada saat terjadi perubahan dan tidak mengirimkan semua routing Tables pada Priodik Update
-          Secara Scalables lebih baik di banding Routing Protocol Distance Vecor

#. OSPF TroubleShoot Tables

1.       Neighbor Table
-          Menampilkan informasi tetangga yang saling terhubung atau bisa juga di sebut Adjaency Database
-          Command: show ip ospf neighbor

2.       Database Table
-          Menampilkan informasi rute dalam satu area yang di gunakan untuk menuju Network, atau biasa disebut juga LSDB (Link State Database)
-          Command:  show ip ospf database

3.       Routing Table
-          Menampilkan informasi best route untuk network tujuan.
-          Command: show ip route

#. Dua langkah membuat routing dynamic di cisco-CCNA:
1.       Pilih Routing Protocol (ospf, rip, eigrp, isis, dll)
2.       mengAdvertise (mengenalkan) masing Network yang terhubung di router.

#. Konfigurasi OSPF
 Router(config)# router ospf <process-id>
Router(config-router)# network <network-id> <wildcard-mask> area <area-id>
-          Keterangan:
1.       <Network-id>: IP Network yang akan di advertise
2.       <Area-id>: nomer area, 0 (backbone area)
3.       <wildcard-mask>: inverse nilai biner(bit) SubnetMask.
4.       <process-id>: nomor dari ospf yang akan di konfigurasi

#. Lab OSPF CISCO CCNA
1.       Lab 1 Single area, area 0 (backbone).
2.       Lab 2 Multiple area, gabungan backbone area sama none backbone area.

-          #. TOPOLOGY Lab 1 Single Area

-          Keterangan:
1.       N= Network
2.       IDN..= Nama Router sesuai urutan nomer
3.       GI= port interface gigabyte
4.       Fa= port interface Fast Ethernet
5.       Area 0= Single Area

#. Konfigurasi tiap – tiap Router
-          R1:
 Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname idn1
idn1(config)#int gi0/0
idn1(config-if)#ip add 10.0.0.1 255.255.0.0
idn1(config-if)#no shut
idn1(config)#exit
idn1(config)#int gi0/1
idn1(config-if)#ip add 192.168.1.1 255.255.255.0
idn1(config-if)#no shut
idn1(config)#exit
idn1(config)#router ospf 1
idn1(config-router)#network 10.0.0.0 0.0.255.255 area 0
idn1(config-router)#network 192.168.1.0 0.0.0.255 area 0
idn1(config-router)#exit

-          R2:
 Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname idn2
idn2(config)#int gi0/0
idn2(config-if)#ip add 10.0.0.2 255.255.0.0
idn2(config-if)#no shut
idn2(config-if)#exit
idn2(config)#int gi0/1
idn2(config-if)#ip add 20.0.0.1 255.255.0.0
idn2(config-if)#no shut
idn2(config-if)#exit
idn2(config)#int gi0/2
idn2(config-if)#ip add 192.168.2.1 255.255.255.0
idn2(config-if)#no shut
idn2(config-if)#exit
idn2(config)#router ospf 1
idn2(config-router)#network 10.0.0.0 0.0.255.255 area 0
idn2(config-router)#network 20.0.0.0 0.0.255.255 area 0
idn2(config-router)#network 192.168.2.0 0.0.0.255 area 0
idn2(config-router)#exit
-          R3:
 Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname idn3
idn3(config)#int gi0/0
idn3(config-if)#ip add 20.0.0.2 255.255.0.0
idn3(config-if)#no shut
idn3(config-if)#exit
idn3(config-if)#int gi0/1
idn3(config-if)#ip add 192.168.3.1 255.255.255.0
idn3(config-if)#no shut
idn3(config-if)#exit
idn3(config)#route ospf 1
idn3(config-router)#network 20.0.0.0 0.0.255.255 area 0
idn3(config-router)#network 192.168.3.0 0.0.0.255 area 0
idn3(config-router)#exit

#. Verifikasi: cek routing Table di salah satu router, seperti Command yang di sebutkan di atas:

-          R1: cek table Routing:
 idn1(config)#do sh ip routeCodes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 Gateway of last resort is not set
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/16 is directly connected, GigabitEthernet0/0
L       10.0.0.1/32 is directly connected, GigabitEthernet0/0
     20.0.0.0/16 is subnetted, 1 subnets
O       20.0.0.0/16 [110/2] via 10.0.0.2, 00:22:43, GigabitEthernet0/0     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/1
L       192.168.1.1/32 is directly connected, GigabitEthernet0/1
O    192.168.2.0/24 [110/2] via 10.0.0.2, 00:22:43, GigabitEthernet0/0O    192.168.3.0/24 [110/3] via 10.0.0.2, 00:22:43, GigabitEthernet0/0

-          R1: Menampilkan Routing OSPF
 idn1(config)#do sh ip route ospf     20.0.0.0/16 is subnetted, 1 subnets
O       20.0.0.0 [110/2] via 10.0.0.2, 00:08:30, GigabitEthernet0/0
O    192.168.2.0 [110/2] via 10.0.0.2, 00:06:30, GigabitEthernet0/0
O    192.168.3.0 [110/3] via 10.0.0.2, 00:06:30, GigabitEthernet0/0

-          R2: Menampilkan informasi Neighbor:
 idn2(config)#do sh ip ospf neighbor Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.1       1   FULL/DR         00:00:36    10.0.0.1        GigabitEthernet0/0
192.168.3.1       1   FULL/BDR        00:00:34    20.0.0.2        GigabitEthernet0/1

-          R3: Menampilkan Routing Protocol:
 idn3(config)#do sh ip protocol Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.3.1  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4  Routing for Networks:
    20.0.0.0 0.0.255.255 area 0    192.168.3.0 0.0.0.255 area 0  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          110      00:07:50
    192.168.2.1          110      00:07:47
    192.168.3.1          110      00:07:45
  Distance: (default is 110)

-          R3: Menampilkan informasi Database OSPF:
 idn3(config)#do sh ip ospf database            OSPF Router with ID (192.168.3.1) (Process ID 1)
                 Router Link States (Area 0)
 Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.3.1     192.168.3.1     136         0x80000005 0x00c10b 2
192.168.2.1     192.168.2.1     139         0x80000007 0x004363 3
192.168.1.1     192.168.1.1     136         0x80000005 0x00f8ee 2
                 Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
20.0.0.2        192.168.3.1     136         0x80000002 0x00b326
10.0.0.2        192.168.2.1     139         0x80000002 0x007d8d

#. Test: Ping dan Tracert pada PC Router IDN1 ke PC Router IDN3:
-          Ping:
 PC>ping 192.168.3.2 Pinging 192.168.3.2 with 32 bytes of data:
 Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
 Ping statistics for 192.168.3.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

-          Tracert:
 PC>tracert 192.168.3.2 Tracing route to 192.168.3.2 over a maximum of 30 hops:
   1   1 ms      0 ms      0 ms      192.168.1.1
  2   1 ms      0 ms      0 ms      10.0.0.2
  3   0 ms      0 ms      0 ms      20.0.0.2
  4   12 ms     0 ms      0 ms      192.168.3.2
 Trace complete.

-          #. TOPOLOGY Lab 2 Multiple Area:

-          Keterangan:
1.       N= Network
2.       IDN..= Nama Router sesuai urutan nomer
3.       GI= port interface gigabyte
4.       Fa= port interface Fast Ethernet
5.       Area = kelompok Area (Multiple Area)

#. Konfigurasi tiap – tiap Router, selebihnya konfigurasikan IP Address dulu (seperti yang di Single Area):
-          R1:
 idn1(config)#route ospf 1
idn1(config-router)#network 10.0.0.0 0.0.255.255 area 10
idn1(config-router)#network 192.168.1.0 0.0.0.255 area 10
idn1(config-router)#exit
-          R2:
 idn2(config)#route ospf 1
idn2(config-router)#network 10.0.0.0 0.0.255.255 area 10
idn2(config-router)#network 20.0.0.0 0.0.255.255 area 20
idn2(config-router)#network 192.168.2.0 0.0.0.255 area 0
idn2(config-router)#exit

-          R3:
 idn3(config)#route ospf 1
idn3(config-router)#network 20.0.0.0 0.0.255.255 area 20
idn3(config-router)#network 192.168.3.0 0.0.0.255 area 20
idn3(config-router)#exit

#. Verifikasi: cek routing Table di salah satu router, seperti Command yang di sebutkan di atas:
-          R1: Menampilkan Table Routing:
 idn1(config)#do sh ip routeCodes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 Gateway of last resort is not set
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/16 is directly connected, GigabitEthernet0/0
L       10.0.0.1/32 is directly connected, GigabitEthernet0/0
     20.0.0.0/16 is subnetted, 1 subnets
O IA    20.0.0.0/16 [110/2] via 10.0.0.2, 00:08:59, GigabitEthernet0/0     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/1
L       192.168.1.1/32 is directly connected, GigabitEthernet0/1
O IA 192.168.2.0/24 [110/2] via 10.0.0.2, 00:08:59, GigabitEthernet0/0O IA 192.168.3.0/24 [110/3] via 10.0.0.2, 00:07:30, GigabitEthernet0/0

-          R2: Menampilkan informasi tetangga:
 idn2#sh ip ospf neighbor Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.3.1       1   FULL/DR         00:00:31    20.0.0.2        GigabitEthernet0/1
192.168.1.1       1   FULL/BDR        00:00:36    10.0.0.1        GigabitEthernet0

-          R3: Menampilkan Informasi databse OSPF
 idn3(config)#do sh ip ospf database            OSPF Router with ID (192.168.3.1) (Process ID 1)
                 Router Link States (Area 20) Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.1     192.168.2.1     544         0x80000004 0x0082ca 1
192.168.3.1     192.168.3.1     530         0x80000003 0x00c509 2
                 Net Link States (Area 20)
Link ID         ADV Router      Age         Seq#       Checksum
20.0.0.2        192.168.3.1     547         0x80000001 0x003938
                 Summary Net Link States (Area 20)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     192.168.2.1     768         0x80000001 0x00abda
10.0.0.0        192.168.2.1     748         0x80000002 0x00eef7
192.168.1.0     192.168.2.1     584         0x80000003 0x00bcc7

#. Test: Ping dan Tracert pada PC Router IDN1 ke PC Router IDN3:
-          Ping:
 PC>ping 192.168.3.2 Pinging 192.168.3.2 with 32 bytes of data:
 Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
Reply from 192.168.3.2: bytes=32 time=13ms TTL=125
Reply from 192.168.3.2: bytes=32 time=0ms TTL=125
Reply from 192.168.3.2: bytes=32 time=1ms TTL=125
 Ping statistics for 192.168.3.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 13ms, Average = 3ms

-          Tracert:
 PC>tracert 192.168.3.2 Tracing route to 192.168.3.2 over a maximum of 30 hops:
   1   0 ms      0 ms      0 ms      192.168.1.1
  2   0 ms      0 ms      0 ms      10.0.0.2
  3   0 ms      0 ms      0 ms      20.0.0.2
  4   0 ms      0 ms      0 ms      192.168.3.2
 Trace complete.
#. Extra
                konfigurasi tambahan apabila di perlukan atau hanya sebagai pengetahuan saja:


-          Advertise menggunakan interface LOOPBACK: lihatlah perbedaannya antara advertise menggunakan interface Physically dengan interface LOOPBACK, dengan konfigurasi interface loopback berikut ini(hapus konfigurasi OSPF advertise Physically, kemudian coba buat ini di tiap – tiap  Router):
1.       Buatlah IP pada interface Loopback di tiap – tiap router:
idn1(config)#int lo1
idn1(config-if)#ip add 1.1.1.1 255.255.255.255
idn1(config-if)#exit

2.       Advertise OSPF menggunakan IP interface LOOPBACK(lakukan di tiap – tiap Router:
Router(config)#router ospf3
Router(config-router)#network 1.1.1.1 255.255.255.255 area 0
Router(config-router)#exit

3.       Cek:
Router(config)#do sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 10.0.0.2, 00:04:12, GigabitEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/129] via 10.0.0.2, 00:03:38, GigabitEthernet0/0
     10.0.0.0/16 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, GigabitEthernet0/0
     20.0.0.0/16 is subnetted, 1 subnets
O       20.0.0.0 [110/128] via 10.0.0.2, 00:04:12, GigabitEthernet0/0
C    192.168.1.0/24 is directly connected, GigabitEthernet0/1
O    192.168.2.0/24 [110/65] via 10.0.0.2, 00:04:12, GigabitEthernet0/0
O    192.168.3.0/24 [110/129] via 10.0.0.2, 00:03:38, GigabitEthernet0/0
                Lihatlah apa yang terjadi ketika Advertise pada Interface Loopback, otomatis OSPF akan mengAdvertise seluruh Network Physically, meskipun yang di Advertise pada interface Loopback.

-          Setting Router-id OSPF: berguna untuk merubah Router-id OSPF.
 R1(config)#router ospf 1
R1(config-router)#router-id 111.111.111.111
R1(config-router)#Reload or use "clear ip ospf process" command, for this to take effect
                Setelah itu jalankan command “clear ip ospf process” yang berguna untuk mereset process ospf sehingga router-id pada OSPF akan berubah.
 R1#clear ip ospf process
Reset ALL OSPF processes? [no]: yes
 R1#
06:12:37: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet1/0 from FULL
to DOWN, Neighbor Down: Adjacency forced to reset
 06:12:37: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet1/0 from FULL
to DOWN, Neighbor Down: Interface down or detached
 R1#
06:12:41: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.4.4 on FastEthernet1/0 from
LOADING to FULL, Loading Done
                Setelah itu lakukan pengecekan OSPF neighbor, maka akan berubah pada Router-id OSPF yang di ganti, dengan command “Show ip ospf neighbor”

-          Setting passive-interface OSPF: berguna untuk menghentkan Hello Packet sehingga mencegah router untuk membentuk Relationship Neighbor yang berakibat pada update routing outgoing dan incoming (tidak dapat mengirim update routing dan juga tidak dapat di kirimi updat routing). (tidak di sarankan pada Stub-Network)
 R1(config)#router ospf 1
R1(config-router)#passive-interface fa0/0
R1(config-router)#
                Lalu coba melakukan cek tabel routing apa yang akan terjadi, untuk mengembalikannya (tanpa passive-interface) dengan tambahan command “no” seperti ini “no passive-interface fa0/0” lakukan banyak eksperimen maka akan semakin tahu untuk menangani masalah.

-          Keuntungan menggunakan OSPF:
1.       Open standard
2.       Tidak terbatas pada jumlah Hop
3.       Loop free
4.       Konvergensi cepat

-          Kekurangan pada OSPF:
1.       Memakan banyak resource CPU
2.       Kompleks pada design dan implementasi
3.       Hanya mendukung equal Load balancing
4.       Hanya mendukung protocol IP


Sekian dulu pada pembahasan routing Dynamic OSPF  semoga bisa membantu dan bermanfaat bagi kita semua, mohon Maaf kalau ada kekurangan dan kesalahan, mohon kritik dan sarannya, terimakasih.

Tolong Laporkan Jika Ada Link Yang Error Atau Gambar Tidak Muncul :)
dan mohon untuk mengklik iklan banner untuk kelangsungan blog :)"
Sekalian juga untuk biaya sekolah admin nya. :) terimakasih :)
EmoticonEmoticon