1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
|
Router(config)# hostname R1
R1(config)# enable secret cisco
R1(config)# line con 0
R1(config-line)# password cisco
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exec-timeout 30 0
R1(config-line)# exit
R1(config)# line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exec-timeout 30 0
R1(config-line)# exit
R1(config)# line aux 0
R1(config-line)# password cisco
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exec-timeout 30 0
R1(config-line)# exit
R1(config)# banner motd $
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
UNAUTHORIZED ACCESS IS PROHIBITED
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
$
R1(config)# alias exec c configure terminal
R1(config)# alias exec s show ip interface brief
R1(config)# alias exec sr show running-config
R1(config)# no ip domain-lookup
R1(config)# service password-encryption
R1(config)# ip domain-name example.com
R1(config)# username admin password cisco
R1(config)# crypto key generate rsa
How many bits in the modulus [512]: 1024
R1(config)# ip ssh version 2
R1(config)# line vty 0 4
R1(config-line)# login local
R1(config-line)# transport input telnet ssh
|
Konfigurasi router interfaces:
1
2
3
4
5
6
7
8
9
10
|
R1(config)# interface fastEthernet 0/0
R1(config-if)# description LINK TO LOCAL LAN THROUGH SW1
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial 0/1/0
R1(config-if)# description WAN CONNECTION TO R2
R1(config-if)# ip address 10.1.1.1 255.255.255.252
R1(config-if)# clock rate 128000
R1(config-if)# no shutdown
|
Konfigurasi Router-On-Stick for vlanrouting:
1
2
3
4
5
6
7
8
|
R1(config)# interface fastEthernet 0/0
R1(config-if)# no shutdown
R1(config)# interface fastEthernet 0/0.10
R1(config-subif)# encapsulation dot1q 10
R1(config-subif)# ip address 192.168.10.1 255.255.255.0
R1(config-subif)# interface fastEthernet 0/0.20
R1(config-subif)# encapsulation dot1q 20
R1(config-subif)# ip address 192.168.20.1 255.255.255.0
|
Static route:
- Using next hop:
1
|
R1(config)# ip route 10.1.2.0 255.255.255.0 10.1.128.1
|
- Using exit interface:
1
2
|
R1(config)# ip route 10.1.2.0 255.255.255.0 Serial 0/0
*Note: Exit interface can be used in point-to-point serial links.
|
Default Route:
1
|
R1(config)# ip route 0.0.0.0 0.0.0.0 199.1.1.1
|
1
2
3
4
5
|
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# network 10.0.0.0 ! written as an original class A
R1(config-router)# no auto-summary
R1(config-router)# passive-interface serial 0/0
|
RIPv2 Verification:
- Shows information about the running routing protocol process:
1
|
R1# show ip protocols
|
- Shows the entire routing table:
1
|
R1# show ip route
|
- Shows routes learned via RIP only:
1
|
R1# show ip route rip
|
- Shows detailed information about the route to the specified destination network:
1
|
R1# show ip route 10.1.1.1
|
OSPF Configuration:
- Enter OSPF router configuration mode:
1
|
R1(config)# router ospf 10 ! 10 = process ID
|
- Configure one or more network commands to identify which interfaces will run OSPF:
1
2
3
|
R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# network 172.16.8.0 0.0.7.255 area 0
R1(config-router)# network 192.168.1.254 0.0.0.0 area 1
|
- Configure router ID either (Optional):
1
|
R1(config-router)# router-id 1.1.1.1
|
Konfigurasi an IP address on a loopback interface:
1
2
|
R1(config)# interface loopback 0
R1(config-if)# ip address 1.1.1.1 255.255.255.255
|
- Change Hello and Dead intervals per interface (Optional):
1
2
|
R1(config-if)# ip ospf hello-interval 2
R1(config-if)# ip ospf dead-interval 6
|
- Impact routing choices by tuning interface cost using one of the following ways (Optional):
1
|
R1(config-if)# ip ospf cost 55
|
Changing interface bandwidth:
1
|
R1(config-if)# bandwidth 128 ! in Kbps
|
Changing the reference bandwidth that used by OSPF to calculate the cost:
1
|
R1(config-router)# auto-cost reference-bandwidth 1000 ! in Mbps
|
- Disabling OSPF on a certain interface (Optional):
1
|
R1(config-router)# passive-interface serial 0/0
|
- Konfigurasi OSPF authentication (Optional):
1
|
R1(config-if)# ip ospf authentication null
|
Type 1 authentication (clear text):
1
2
|
R1(config-if)# ip ospf authentication
R1(config-if)# ip ospf authentication-key cisco
|
Type 2 authentication (md5):
1
2
|
R1(config-if)# ip ospf authentication message-digest
R1(config-if)# ip ospf message-digest-key 1 md5 cisco
|
- Configure maximum equal-cost paths (Optional):
1
|
R1(config-router)# maximum paths 6
|
OSPF verification:
- Shows information about the running routing protocol process:
1
|
R1# show ip protocols
|
- Shows the entire routing table:
1
|
R1# show ip route
|
- Shows routes learned via OSPF only:
1
|
R1# show ip route ospf
|
- Shows all neighboring routers along with their respective adjacency state:
1
|
R1# show ip ospf neighbors
|
- Shows all the information contained in the LSDB:
1
|
R1# show ip ospf database
|
- Shows detailed information about OSPF running on a specific interface:
1
|
R1# show ip ospf interfaces serial 0/0
|
- Enter EIGRP configuration mode and define AS number:
1
|
R1(config)# router eigrp 121 ! 121 = AS number
|
- Configure one or more network commands to enable EIGRP on the specified interfaces:
1
2
3
4
|
R1(config-router)# network 10.0.0.0
R1(config-router)# network 172.16.0.0 0.0.3.255
R1(config-router)# network 192.168.1.1 0.0.0.0
R1(config-router)# network 0.0.0.0 255.255.255.255
|
- Disable auto summarization (Optional):
1
|
R1(config-router)# no auto-summary
|
- Disable EIGRP on a specific interface (Optional):
1
|
R1(config-router)# passive-interface serial 0/0
|
- Configure load balancing parameters (Optional):
1
2
|
R1(config-router)# maximum-paths 6
R1(config-router)# variance 4
|
- Change interface Hello and Hold timers (Optional):
1
2
|
R1(config-if)# ip hello-interval eigrp 121 3
R1(config-if)# ip hold-time eigrp 121 10
|
- Impacting metric calculations by tuning BW and delay of the interface (Optional):
1
2
|
R1(config-if)# bandwidth 265 ! in Kbps)
R1(config-if)# delay 120 ! tens of microseconds
|
EIGRP Authentication:
- Create an authentication key chain as follows:
1
|
R1(config)# key chain MY_KEYS
|
Create one or more keys giving them numbers:
1
|
R1(config-keychain)# key 1
|
Define the key value:
1
|
R1(config-keychain-key)# key-string1stKEY
|
Define the life time of the keys (optional):
1
2
|
R1(config-keychain-key)# send-lifetime [start time] [end time]
R1(config-keychain-key)# accept-lifetime [start time] [end time]
|
- Enable md5 authentication mode for EIGRP on the interface:
1
|
R1(config-if)# ip authentication mode eigrp121 md5
|
- Refer to the correct key chain to be used on the interface:
1
|
R1(config-if)# ip authentication key-chain eigrp121 MY_KEYS
|
EIGRP Verification:
- Shows routes learned via EIGRP only:
1
|
R1# show ip route eigrp
|
- Shows EIGRP neighbors and status:
1
|
R1# show ip eigrp neighbors
|
- Shows EIGRP topology table, including successor and feasible successor:
1
|
R1# show ip eigrp topology
|
- Shows interfaces that run EIGRP:
1
|
R1# show ip eigrp interfaces
|
- Lists statistics on numbers of EIGRP messages sent and received by the router:
1
|
R1# show ip eigrp traffic
|
Tolong Laporkan Jika Ada Link Yang Error Atau Gambar Tidak Muncul :)
dan mohon untuk mengklik iklan banner untuk kelangsungan blog :)"
Sekalian juga untuk biaya sekolah admin nya. :) terimakasih :)
EmoticonEmoticon